Saturday, January 15, 2011

Error generating final archive: xxx\bin\resources.ap_ does not exist

It's a unknown packaging problem.

Delete the error and the "Unparsed aapt error(s)!" error message that you are also likely to see. Then Go to Project-> Clean.

Choose "Clean projects selected below" and the project you are encountering problems in. Restart your Eclipse.

Updated!!!( 24th Jan 2011)
Had feedback from Bin (see comment below) that it does not work. I am grateful for his comment, even though I must admit it was rather grating on my ego. Oh ya, you got to restart your Eclipse. I forgot to mention it. 

I went to do some research on it. Seems like some of the people who cleaned the project like me, could solve the problem, and some couldn't. That is sehr unlucky I would say.

In that case, I recommend that you use the same old Eclipse tricks.
(1)  Undo your last change, esp if you did something to something in your res folder.
(2) Definitely restart your Eclipse. Be extra kiasu and delete the app in your phone or close off the emulator beforehand.
(3) Check that you have the correct Android target (right click on your project -> go to Properties->Android)
(4) Run the app again.

This is interesting, and somewhat ironic. After I typed this in, this stupid error happened to me too.  Again. (Damn you Android!!) This time cleaning did not help immediately. In fact it was because I tried the 9 patch png, which Android could not interpret correctly, therefore screwing  my (I suspect) and all my other resources (which were declared in another layout xml). I would call it bad juju.

Anyway I had to wipe out the stupid png, before doing the above steps. The above cleaning solution then worked fine for me, in the end.

Oh yeah, if it works for you this time, please say so. If not, please also state your solution, so that others  (such as yours truly *haha*) can benefit from thy wisdom. TY! 

Googlers (I am assuming you are since you are coming from Mountain View, California) be a buddy, and provide the solution if you have one. thanks! 


  1. I got the same problem in my program. At the beginning, I created a xml res file and there was a error. Tried to fix and failed. Then this ".../resources.ap_does not exist" came to my program. Clean and rebuild didn't work. So I deleted the xml res file and recreated it. Problem gone.

  2. For me, the problem was with a jpg file I had saved in the resources as a png. Deleted the file, cleaned the project and everything is working again.
    The Console output when you try to clean the project might give a hint about the problem.

  3. Faça o seguite para resolver o problema do resources.ap_
    1. Feche seu motodev studio ou eclipse
    2. Na pasta de instalação do AndroidSDK execute o arquivo "SDK Manager.exe".
    3. No Painel Android SDK Manager marque o CheckBox Tools e clique em Install 2 packges...
    4. Clique em Accept All.
    5. Assim que terminar a instalação, feche este Painel.
    6. Abra o Motodev, Eclipse ou ADT e clique em Window > Android SDK Manager, espere carregar e feche-o.
    7. Pronto, agora é só criar um projeto para testar.
    Abraços Fabio Santos -

    Do seguite to solve the problem of resources.ap_
    1. Close your MOTODEV Studio or eclipse
    2. In the installation folder AndroidSDK run the file "SDK Manager.exe".
    3. Panel Android SDK Manager select the CheckBox Tools and click Install ... 2 packges
    4. Click Accept All.
    5. Once installation is finished, close this panel.
    6. Open the MOTODEV, Eclipse or ADT and click Window> Android SDK Manager, wait to load and close it.
    7. Okay, now just create a project for testing.
    hugs Fabio Santos -



Related Posts with Thumbnails